KB Home | Advanced Search

Knowledgebase

Knowledgebase Home >> Help

Java(TM) Fatal Error

Error:
The Java Runtime Environment cannot be loaded

Example messages you may receive are;





Fix:

1. Click the Start button, go to your Control Panel, and go to Add/Remove Programs.
2. Uninstall all instances of Java
3. Go to C:Program FilesJava and delete all the folders
4. Reboot your computer
5. Download and install the latest version of Java; http://www.java.com/en/

Your SK installation should then operate normally. If it doesn't, read below this.

If the above fails:

Try changing your Java types. If you have Sun Java, try MS Java. Vise-versa applies.

You can download both HERE.

Once downloaded you will need to ensure that the new Java type is your "default" one that SwiftKit will use.

To do this;

1. Open Internet Explorer (even if this is not your default browser, SwiftKit takes it's setting from IE).

2. On Internet Explorer go Tools > Internet Options > Advanced (Tab) > then scroll down to 'Java (Sun)' and either UNTICK the box if you are swapping to MS Java or TICK the box if you are swapping to Sun Java.

3. Then 'Apply' and 'Ok' and close Internet Explorer

4. Reboot your computer.

5. Relaunch SK, when you get to the "Detail Select" page on the RS site, scroll down and doublecheck that you have the dropdown set on the "Signed Applet Using Default Java" option.

Article Options
  |    Email this page   |    Print this page
User Opinions...

85% 15% from a total of 277 votes.

How would you rate this answer?
Helpful Not helpful

Visitor Comments
an unknown user posted...

tried both didn;t work


an unknown user posted...

Neither worked


Rafa posted...

Thanks for this I uninstalled everything Java related on my pc, restarted my computer and downloaded "Java SE 6 Runtime (JRE) Update 10 build 25 Windows Online Installer". After the installation I opened SK and now it works fine. Thank You again :)


DAN posted...

THANK YOU WORKS JUST FINE NOW


an unknown user posted...

didnt work.


torgortega posted...

I did the same as comment #3. Had to delete it all and reinstall. It worked.


Frankie posted...

Method 2 worked for me. Thanks.


Jim Gator posted...

If I remove java SE and install the MS Java VM will it still work on mozilla because I hate IE? I can load Swift Switch but not Swift Kit. I hate deleting all of my Java just for Swift Kit which one app specific. I have tried all the patches and everything else that has been suggested here and still get "Java Runtime cannot........" That didn't work. I am really stuck here. Thx Jim_Gator


Scarfaceleo posted...

Omg! Ty. I've already tried upgrading my gfx card and uninstalling then installing the Java app again and none of that worked. What worked for me was Method 2. Once again, ty! I got tired of using Tiko. =/ <3 SK! -Scarfaceleo


Eric posted...

Thanks! Method 2 worked like a charm!


an unknown user posted...

Method 1 didn't work, but method 2 helped. Restarted comp then launched SK and Java seemed to work perfectly. Thx


an unknown user posted...

wow i did the second one and with worked, thank you!


mumj9 posted...

omg idk wat to say but im very thankfull for method 2 lol nvm wat i say but i thank u all it worled method 2 with the help of commet 3 i thank u all again c ya and hava a nice day


funtime posted...

Thank You, method 2 finally worked to fix this damn problem!!!


an unknown user posted...

I tried method 2 and it's worked thank you.


Alex posted...

Method 1 Worked. Thanks.


an unknown user posted...

neither worked


Call Me Lode posted...

Well, i cant load RuneScape in Swiftkit because my java aint enabled NOT because of my version because i have newest version, how do i enbal it?


© 2004 - 2010 - Bluelight Dev. All rights reserved.
This site is in no way affiliated with Jagex Ltd. ToS