KB Home | Advanced Search

Knowledgebase

Knowledgebase Home >> Frequently Asked Questions (FAQ)

How to rename SwiftKit-RS.exe so it works with xfire

In order for Xfire to see SwiftKit-RS as RuneScape you need to rename SwiftKit-RS.exe to runescape.exe.

 

SwiftKit Setup

To do this you will need to add a setting to the GlobalSettings.ini file.

Go to your SwiftKit installation folder. By default this is C:\Program Files\SwiftKit

  1. Open the Data folder and double click(or open in notepad) on GlobalSettings.ini.
  2. Under [Startup Options] add; RS_Exe_Name=runescape

So the end result should look something like this;

[Startup Options]
Host=UK 2
RS_Exe_Name=runescape

Save and close GlobalSettings.ini You can now go ahead and right click 'rename' your SwiftKit-RS.exe file to runescape.exe

 

XFire Setup

  1. Open Xfire
  2. Click Tools > Options
  3. Click the "games" tab



  4. Click not installed
  5. Click RuneScape
  6. Click manual setup
  7. Type in the path name to the Swiftkit folder (By default this is C:\Program Files\SwiftKit)

  8. Click apply
 
 

 



As of April 30th 2010 Xfire as locked out the ability to choose manual setup. To allow Xfire to detect SwiftKit you will need to do the following.

 

SwiftKit Setup

 To do this you will need to add a setting to the GlobalSettings.ini file.

Go to your SwiftKit installation folder. By default this is C:\Program Files\SwiftKit

  1. Open the Data folder and double click(or open in notepad) onGlobalSettings.ini.
  2. Under [Startup Options] add; RS_Exe_Name=runescape

So the end result should look something like this;

[Startup Options]
Host=Main Server
RS_Exe_Name=runescape

Save and close GlobalSettings.ini You can now go ahead and right click 'rename' your SwiftKit-RS.exe file to runescape.exe

 

XFire Setup

 1. Go to you Xifre install folder

Windows 7/Vista - "C:\ProgramData\Xfire"

Windows XP - "C:\program files\xfire"

 2. Open xfire_games.ini in Notepad

 3. Click the Edit menu then click find.

 4. type in "runescape" and click  "Find Next"

 5. This will show you the settings for RuneScape that Xfire will use. Change the second RuneScape Block "[5303_2]" to the following

[5303_2]

LongName=RuneScape

ShortName=scap

LauncherDirDefault=C:\Program Files\SwiftKit

LauncherExe=runescape.exe

Launch=%UA_LAUNCHER_EXE_PATH% %UA_LAUNCHER_EXTRA_ARGS% %UA_LAUNCHER_NETWORK_ARGS% 

 

 please note that for 64bit users you may need to change "Program Files" to "Program Files(x86)"

  6. click File > Save then  reopen Xfire. Xfire should now detect SwiftKit.

Article Options
  |    Email this page   |    Print this page
User Opinions...

77% 23% from a total of 52 votes.

How would you rate this answer?
Helpful Not helpful

Visitor Comments
Big Stingman posted...

THANK YOU SO MUCH!


Steven posted...

ty guys


II SpraY II posted...

Thank you so very, very much! finally I can play rs on swiftkit and get my hrs to show on xfire! thank you!!!! II SpraY II


Cody posted...

Needs to be updated, xfire has disabled to ability to do this..


Big Stingman posted...

Hm yeah Xfire doesn't seem to let you do it anymore. I just use the Xfire toolbar now though.


Raian the Fallen posted...

Dammit Xfire. Just dammit.


Purple Materia posted...

If it stops working, it's because Xfire updated the Xfire_Games.ini. Just re-add the text to it and you'll be good to go.


Sean posted...

This no longer works, theres no xfire_games.ini =\ o well


© 2004 - 2010 - Bluelight Dev. All rights reserved.
This site is in no way affiliated with Jagex Ltd. ToS