KB Home | Advanced Search

Knowledgebase

Knowledgebase Home >> SwiftKit for Mac

I get a coffee cup and red exclimationmark when I try to load RuneScape.

This is caused by providing incorrect paramaters to Java. This is often done when attempting to increase the amount of memory that Java has access to.
 
Open Java Preferences (/Applications/Utilities/Java Preferences/) or search it in Spotlight.
 
Under the General tab, for each configuration in the list box, select it and click the "Options..." button. Make sure "-Xmx200m" is written. It must be written exactly like that and is caps sensitive. The "200m" part specifies how much memory Java can use - which you can increase from 200 if you would like (granted your machine can handle it).

If this doesn't work, just remove the "-Xmx200m" completely.

If there are any other parameters in these boxes other than -Xmx, use the process of elimination to find out which one is causing the error. 

Article Options
  |    Email this page   |    Print this page
User Opinions...

33% 67% from a total of 15 votes.

How would you rate this answer?
Helpful Not helpful

Visitor Comments
Carrieann posted...

I feel so much happier now I unerdtsnad all this. Thanks!


© 2004 - 2010 - Bluelight Dev. All rights reserved.
This site is in no way affiliated with Jagex Ltd. ToS