KB Home | Advanced Search

Knowledgebase

Knowledgebase Home >> Help

SwiftKit is telling me that there is a firewall blocking the connection, is it really that?

Many times we've had users tell us that they get a firewall error or cannot connect to any of the update servers, and they're absolutely positive that it's not their firewall. Here is a test to prove, or disprove that.

Note: Please try ALL update servers before you attempt this. One might simply be offline.

1. Download and install Fiddler.
2. When you have that up, make sure the 'Capturing' text is up in the bottom-left (if it isn't, File > Capture Traffic).
3. Leave it open and try to launch SwiftKit.
4. The key thing to watch here is the query for the 'FileVersion.ini' file (picture).

If it doesn't show up at all, then there is a firewall and something's not allowing that HTTP transfer.

If it does show up, but there's an error of some sort (it's red), then it's a problem with the server connection. Post the problem in the SwiftKit forums so the appropriate staff can take a look at it.

If it does show up and it looks like the picture, it should be working just fine, and it is indeed not a firewall issue. It might not work then because you may not have write permissions. Try re-installing SwiftKit to your My Documents folder where you have full access.

Hopefully with this article we can set matters straight and get to the bottom of the problem.

Article Options
  |    Email this page   |    Print this page
User Opinions...

41% 59% from a total of 29 votes.

How would you rate this answer?
Helpful Not helpful

Visitor Comments
Jason posted...

firstly that email is real. but this is my issue. I was using SK perfectly fine, i restarted my pc and then SK was unable to connect to the update server. I tried all servers/restarted pc/ reinstalled SK. I found this article so i installed fiddler and found the strangest thing. SK works fine when fiddler is open and running. However, if fiddler is not running then SK is still unable to connect to update server. Any thoughts on what is happening and any possible solutions? Thankyou


Christian posted...

Thanks man this really helped me.


an unknown user posted...

Hey same thing happened to me. I live in the USA and I just changed the server to UK and my swiftkit started to work again


Benny posted...

I have the same thing as Jason, i can only run SK when i have fiddler on. I live in Australia and i really have no idea what's going on. Can anyone help me out?


Aliza posted...

I have the same problem. Swiftkit only connects when I have Fiddler open.


range posted...

Hey thanks this was really helpfull and kind of you guys to take the time to solve this problems thanks! :)


Pat posted...

Thanks so much The Fiddler worked instantly


Solver posted...

Swiftkit only runs while fidler is open? Open your internet options (if you cant find it, open your Internet Explorer browser and do it from there. Its also in your network and sharing center in the control panel) Open the connections tab, and click on "LAN settings" At the very bottom of this box, uncheck "use a proxy server for your LAN......." and also uncheck "bypass a proxy.......". Your welcome.


© 2004 - 2010 - Bluelight Dev. All rights reserved.
This site is in no way affiliated with Jagex Ltd. ToS